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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in this 
guide.

• Procedures are presented as numbered lists. A single bullet indicates that the procedure has only 
one step.
Bold type is used for the following:
- Keyboard entries that should be typed in their entirety exactly as shown. For example, “copy 

file1” means the word copy must be typed, then a space must be typed, and then file1 must 
be typed.

- On-screen prompts and messages, names of options and text boxes, and menu commands. 
Menu commands are often separated by carats. For example, “click HFSS>Exci-
tations>Assign>Wave Port.”

- Labeled keys on the computer keyboard. For example, “Press Enter” means to press the key 
labeled Enter.

• Italic type is used for the following:
- Emphasis.
- The titles of publications.
- Keyboard entries when a name or a variable must be typed in place of the words in italics. For 

example, “copy file name” the word copy must be typed, then a space must be typed, and 
then name of the file must be typed.

• The plus sign (+) is used between keyboard keys to indicate that you should press the keys at the 
same time. For example, “Press Shift+F1” means to press the Shift key and the F1 key at the 
same time.

• Toolbar buttons serve as shortcuts for executing commands. Toolbar buttons are displayed after 
the command they execute. For example,

• “On the Draw menu, click Line ” means that you can click the Draw Line toolbar button to 
execute the Line command.
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Getting Help: ANSYS Technical Support

For information about ANSYS Technical Support, go to the ANSYS corporate Support website, 
www.ansys.com/Support. You can also contact your ANSYS account manager in order to obtain this 
information.

All ANSYS�(0 software files are ASCII text and can be sent conveniently by e-mail. When reporting 
difficulties, it is extremely helpful to include very specific information about what steps were taken or 
what stages the simulation reached, including software files as applicable. This allows more rapid and 
effective debugging.

Help Menu

To access online help from the HFSS menu bar, click Help and select from the menu:

Contents - click here to open the contents of the online help.

Search - click here to open the search function of the online help.

Index - click here to open the index of the online help.

Context-Sensitive Help

To access online help from the HFSS user interface, do one of the following:

• To open a help topic about a specific HFSS menu command, press Shift+F1, and then click the
command or toolbar icon.

• To open a help topic about a specific HFSS dialog box, open the dialog box, and then press F1.

www.ansys.com/Support
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1 Introduction

This document is intended as supplementary material to 
HFSS for beginners and advanced users. It includes 
instructions to create, simulate, and analyze a silicon spi-
ral inductor model.

This chapter contains the following topic:

D Sample Project - Silicon Spiral Inductor



Getting Started with HFSS: Silicon Spiral Inductor

1-2 Introduction 
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Sample Project - Silicon Spiral Inductor
In this project, we will use HFSS to create, simulate, and 
analyze a 2.5 turn spiral inductor.

Figure 1. Spiral Inductor

This nominal design consists of the following components with 
their corresponding dimensions:
•    Spiral: 2.5T, W=15um, S=1.5um, Rad=60um.

M6, 2um, σ= 2.8e7 S/m.
•    Underpass: M5, 0.5um, σ= 2.8e7 S/m.
•    Stackup: Passivation: 0.7um, εr = 7.9.
•    Oxide: 9.8um, εr = 4.0.
•    Substrate: 300um.

εr = 11.9, σ= 10 S/m.
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Figure 2. Passivation, Oxide and Substrate
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2 Set Up The Project

This chapter contains the following topics:

D Launch HFSS
D Set Tool Options
D Insert HFSS design
D Set Model Units(cm)
D Set Solution Type(Terminal)
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Launch HFSS
Store a shortcut of the HFSS application on your desktop.

1  Double-click the HFSS icon to launch the application.

Figure 1. HFSS launched

Note   If the application does not list the folder, go to File 
and click New. If the Project Manager window does not 
appear, go to View and enable it.

Set Tool Options
Verify the options under the Tools menu as follows:
1  Click Tools>Options>HFSS Options.

The HFSS Options dialog box appears.

Figure 2. Assignment Options

2  On the General tab ensure all Assignment Options are 
checked and click OK to close the dialog box.

3  Click Tools>Options>Modeler Options.
The Modeler Options dialog box appears.

4  On the Operation tab check Automatically cover closed 
polylines.
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Figure 3. The option on the Operation tab

5  On the Drawing tab check Edit properties of new primi-
tives and click OK.

Figure 4. option on the Drawing tab

Note   This option causes a Properties dialog box to 
appear automatically whenever you create a new object.

Insert HFSS design
The icon below represents the Insert HFSS design (IHd) 
option.

Figure 5. IHd

1  Expand the project tree.

2  If IHd is present, proceed to rename and save the project 
and if it is absent click the IHd icon to include it.
Note   Inclusion of IHd modifies the project and hence the 
asterisk appears on Project1.

Figure 6. IHd included
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3  Click Project1*, hit F2, rename the project as si_spi-
ral_inductor, and save it.

Set Model Units
Set the units for the geometric model as follows:
1  On the HFSS toolbar, click Modeler> Units.

The Set Model Units dialog box appears.
2  Select the unit as um and click OK.

Figure 7. Set Model Units dialog

Set Solution Type
To set the solution type:
1  On the toolbar, click HFSS> Solution Type

The Solution Type dialog box appears.

Figure 8. Solution Type dialog 

2  Select Driven Terminal and click OK.
Note   Driven Terminal calculates the terminal-based S-
parameters of multi-conductor transmission line ports. The 
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S-matrix solutions will be expressed in terms of terminal 
voltages and currents.
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3 Setup Si Spiral Inductor

This chapter describes how to build the 3D spiral inductor 
model in HFSS.

This chapter contains the following topics:
D Create 3D Model for Dielectrics
D Create Substrate
D Create Oxide
D Create Passivation
D Create Air Body
D Assign Radiation Boundary
D Create Ground
D Assign Perfect E Boundary to the Ground
D Create Spiral Inductor Geometry
D Assign Thickness to the Spiral
D Create Underpass
D Create Via1
D Create Via2
D Create Feed
D Unite Spiral Objects
D Solve Inside Conductors
D Seed Mesh Conductors Set for Solve Inside
D Create Ground Ring
D Create Inner Ring
D Complete The Ring
D Create Extension1
D Create Extension2
D Create Source1
D Create Source2
D Group the Conductors
D Assign Excitation for Source1
D Assign Excitation for Source2
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Create 3D Model for Dielectrics
To create the 3D model, you must draw a number of objects. 
The following sections contain the steps to create the geome-
try.

Create Substrate
To create the substrate, first draw a box freehand as follows:
1  Click Draw>Box.

The cursor is accompanied by a black square box.
2  Click inside the Modeler window to establish the x,y axes 

and drag the mouse to draw a rectangle.
3  Click the mouse to establish the z axis and drag the mouse 

along the z-axis to draw the height.
4  Click the mouse again, to complete the box.

The Properties dialog box appears.

Figure 1. Properties dialog 

5  Edit the fields in the Command dialog box as in Figure 1.
6  On the Attribute, enter Sub in the Name field and from 

the Materials drop-down menu, select Edit.

The Select Definition dialog box appears.
7  Click Add Material and edit the fields in the dialog box as 

shown in Figure 2.
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Figure 2. View/Edit Material dialog 

8  Click OK to close the View/Edit Material dialog box and 
repeat the same on the other dialog boxes to exit.

9  Do Ctrl+D to fit the view.
.

Figure 3. Substrate created
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Create Oxide
To create the oxide, first draw a box and specify its size and 
location as follows:
1  Draw the box freehand.

The Properties dialog box appears.

Figure 4. Command dialog for Oxide

2  On the Command tab, edit the fields as in Figure 4 and 
click Attribute and rename box to: Oxide

3  From the Materials drop-down menu, select Edit.
The Select Definition dialog box appears.

4  Click Add Material and edit the fields as in Figure 5.
Note   The View/Edit Material dialog box appears.

Figure 5. View/Edit Material dialog

5  Click OK to close the View/Edit Material dialog box and 
repeat the same on the other dialog boxes to exit.
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Figure 6.  for the oxide substrate

Create Passivation
To create passivation, draw a box and specify its size and 
location as follows:
1  Draw the box freehand.

Figure 7. Command tab for passivation

2  On the Command tab edit the fields as shown in Figure 7 
and on the Attribute tab rewrite the Name field to Pass.

3  Select Edit from the Materials drop down menu.
4  Click Add Material and edit the fields as in Figure 8.
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Figure 8. View/Edit Material dialog 

5  Click OK to close the View/Edit Material dialog box and 
repeat the same on the other dialog boxes to exit.

Figure 9. Passivation applied.

Create Air Body
To create an air body, draw a box and specify its size and loca-
tion as follows:

1  Draw a box freehand.

2  Set the Command dialog box as in Figure 10.
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Figure 10. Properties dialog for Air

3  On the Attribute tab, rename object to Air.
4  Ensure that the Material selected is vacuum and click OK.

The box gets updated with the new dimensions and prop-
erties that you set.

Figure 11. Air Enclosure drawn

Assign Radiation Boundary
Now assign the radiation boundary to the air box.
1  Select Air from the History Tree dialog box.

The air body gets highlighted.
2  Right click Air and select Assign Boundary>Radiation from 

the short-cut menu.
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The Radiation Boundary dialog box appears.
3  Edit the fields as shown in Figure 12 and click OK.

Figure 12. Radiation Boundary

Create Ground
To create the ground, draw a rectangle as described below.
1  Click Draw> Rectangle.

2  Draw a rectangle freehand.
The Properties dialog box appears.

3  Click OK to accept the values in the Properties dialog box.
4  Double-click CreateRectangle from the history tree.

The Command dialog box appears.

Figure 13. Properties for Rectangle

5  Edit the fields as shown in Figure 13.
The rectangle updates itself with the new settings.

6  Double-click Rectangle1 in the history tree and on the 
Attribute dialog box enter Ground in the Name field and 
click OK.
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Figure 14. The structure with rectangle drawn
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Assign Perfect E Boundary to the Ground
1  Click outside the structure to deselect all 2D and 3D 

objects.

2  Select Ground from the history tree to highlight it.
3  Right-click Ground and select Assign Boundary>Perfect E 

from the short-cut menu.
The Perfect E Boundary dialog box appears.

4  Enter PerfE_Ground in the Name field.

Figure 15. Perfect E boundary dialog 

5  Leave the Infinite Ground Plane unchecked and click OK.
The Perfect E boundary is applied and the Message Man-
ager gives the following warning:
• Boundary Rad1 and Boundary PerfE_Ground overlap.
This is because you applied the PerfE boundary on a face 
that already has the Radiation boundary. However, Per-
fE_Ground overrides the Radiation boundary on that face 
owing to a higher priority. 
Note   By default priority is assigned according to the 
order in which the boundaries are applied. Since 
PerfE_Ground was assigned after Rad1, it has a higher 
priority. HFSS lets you re-prioritize the boundaries, but it 
is not needed for this project.
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Hide Dielectrics
1  Click Edit>Select All Visible

2  Click View>Visibility>Hide Selection>All Views
All the objects are now hidden.

Create Spiral Inductor Geometry
Before you create the spiral inductor, set the default mate-
rial.
1  From the Modeler Materials toolbar, choose Select.

The Select Definition dialog box appears.
2  Click Add Material.

The View/Edit Material dialog box appears.
Edit the fields as shown in Figure 16.

Figure 16. View/Edit Material dialog 

3  Click OK to close the View/Edit Material dialog box and 
repeat the same on the other dialog box to exit.

Create Offset Coordinate System
1  Click Modeler>Coordinate System>Create>Relative 

CS>Offset

2  In the coordinate fields, enter the origin as follows:
X: 0.0, Y: 0.0, Z: 304.8.
Note   The co-ordinate fields appear on the status bar at 
the bottom and are titled Select the origin.

3  Hit Enter.
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Create Spiral Path
To create the spiral draw a Polyline using one of the following 
methods:
• Create Polyline Freehand
• Create Polyline From the Status Bar

Create Polyline Freehand
This section shows how to create the spiral by drawing it free 
hand and then, editing its coordinates. 
1  Click Draw>Line.

2  Click anywhere in the modeler to establish the first point 
and drag the cursor to draw a line and click again, to 
establish the second point as shown in the figure below.

Figure 17. 
3  Continue to drag and click the mouse to establish 13 such 

points as shown in the figure below where we have labeled 
all the 13 points.

4  Right click and select Done from the short cut menu.

point 1
point 2

point 1
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Figure 18. Polyline with 13 points

5  Double-click CreateLine from the history tree and edit the 
coordinates for the vertices in its Segment tab as shown 
below.

Figure 19. Coordinates for Line1

6  Edit the fields for each of the 12 CreateLine options on 
their corresponding Segment tabs as shown below.

1

2

3

4

5

6

7

8

9

10

11

12

13

Line 1
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Figure 20. Coordinates for Line 2 through Line 7

Line 2 

Line 3

Line 4

Line 5

Line 6

Line 7
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Figure 21. Coordinates for Line 8 through Line 12

Line 8

Line 9

Line 10

Line 11

Line 12
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Create Polyline From the Status Bar
In this method, enter the coordinates of the points in the sta-
tus bar as described below.
1  Click Draw>Line.

2  Edit the coordinate entry fields as follows:
Enter the vertex field for point 1:
X: -67.5, Y: 7.5, Z: 1.0 Press the Enter key.
Enter the vertex field for point 2:
X: -67.5, Y: -67.5, Z: 1.0 Press the Enter key.
Enter the vertex field for point 3:
X: 84.0, Y: - 67.5, Z: 1.0 Press the Enter key.
Enter the vertex field for point 4:
X: 84.0, Y: 84.0, Z: 1.0 Press the Enter key.
Enter the vertex field for point 5:
X: - 84.0, Y: 84.0, Z: 1.0 Press the Enter key.
Enter the vertex field for point 6:
X: - 84.0, Y: -84.0, Z: 1.0, Press the Enter key.
Enter the vertex field for point 7:
X: 100.5, Y: -84.0, Z: 1.0, Press the Enter key.
Enter the vertex field for point 8:
X: 100.5, Y: 100.5, Z: 1.0, Press the Enter key.
Enter the vertex field for point 9:
X: - 100.5, Y: 100.5, Z: 1.0, Press the Enter key.
Enter the vertex field for point 10:
X: - 100.5, Y: - 100.5, Z: 1.0, Press the Enter key.
Enter the vertex field for point 11:
X: 117.0, Y: -100.5, Z: 1.0, Press the Enter key.
Enter the vertex field for point 12:
X: 117.0, Y: 0.0, Z: 1.0, Press the Enter key.
Enter the vertex field for point 13:
X: 131.0, Y: 0.0, Z: 1.0, Press the Enter key.

3  Using the mouse, right-click and from the short-cut menu 
select Done.
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4  Select Attribute and enter Spiral in the Name field and 
click OK.

Figure 22. Spiral drawn.

Assign Thickness to the Spiral
To assign trace width and thickness perform the following:
1  Right-click Create Polyline under Spiral from the History 

Tree.

2  Select Properties from the short-cut menu.
The Properties dialog box appears.

Figure 23. History Tree
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Figure 24. Command dialog box

3  Edit the fields as shown in Figure 24 and click OK to close 
the Properties dialog box.
The spiral is assigned the thickness that you set.

Figure 25. The updated spiral
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Create Underpass
Before creating the underpass ensure the grid plane is XY as 
follows:
1  Click Modeler>Grid Plane>XY.

Figure 26. Properties dialog (underpass)

2  Draw a box freehand and edit the fields on the Command 
tab as shown in Figure 26.

3  On the Attribute tab rename object as Underpass and 
click OK to close the Properties dialog box.

Figure 27. The Underpass
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Create Via1
To create the Via, first draw a box.
1  Draw a box freehand and on the Command tab edit the 

fields as shown in Figure 28.

2  On the Attribute tab enter Via1 in the Name field and 
click OK.

Figure 28. Properties dialog Via1

Figure 29. Via1 applied

Create Via2
To create another via, again, draw a box.
1  Draw a box freehand and edit the fields on the Command 
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tab as shown in Figure 30.

Figure 30. Via2 Properties

2  On the Attribute tab enter Via2 in the Name field and 
click OK.

Figure 31. Via2 applied.

Create Feed
1  Draw a box freehand.

The Properties dialog box appears.



Getting Started with HFSS: Silicon Spiral Inductor

3-22 Setup Si Spiral Inductor 
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Figure 32. Feed Properties

2  Edit the fields as shown in Figure 32 and on the Attribute 
tab enter Feed in the Name field and click OK to close the 
Properties dialog box.

3  Do Ctrl+D to fit the view.

Figure 33. Feed applied.

Unite Spiral Objects
You will now unite the spiral objects.
1  Click Spiral, press the Ctrl key and select Via1, Via2, 

Feed, and Underpass.
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Figure 34. The pieces united
Note   The order in which you select the objects 
determines the name of the united structure. For example 
if you select spiral first followed by the rest, the united 
structure will be named spiral. If you select Feed first, 
then, the united structure will be named as Feed.

2  Click Modeler>Boolean>Unite

Figure 35. The united object names itself as spiral

3  Do Ctrl+D to fit the view.
4  Double-click spiral from the history tree and make sure 

Solve Inside is unchecked on the Attribute tab. 
Note The conductive material is represented by a bound-
ary condition that removes the need to solve inside metal.
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Seed Mesh Conductors
In this section you will set HFSS to refine the length of the 
tetrahedral elements until they are below the specified 
value.
1  Click Edit>Select All Visible

2  Click HFSS> Mesh Operations>Assign>Inside Selec-
tion>Length Based
The Element Length Based Refinement dialog box 
appears.

3  Edit the fields as shown in the figure below and click OK.

Figure 36. Element Length Based Refinement settings

Create Ground Ring
To create a ground ring, first draw a box freehand.
1  Click Draw>Box.

2  Draw a box freehand.
The Properties dialog box appears.
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Figure 37. Ring Properties

3  On the Command tab edit the fields as shown in Figure 37.
4  On the Attribute tab enter Ring in the Name field and 

select Edit from the Materials drop-down menu.
The Select Definition window appears.

5  Type pec in the Search by Name field.
6  Click OK to close the View/Edit Material dialog box and 

repeat the same on the other dialog boxes to exit.

Figure 38. Select Definition window
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Figure 39. Ring applied

Create Inner Ring
To create the inner ring, again draw a box.
1  Click Draw>Box.

2  Draw a box freehand.
The Properties dialog box appears.

3  On the Command tab, edit the fields as shown in Figure 
40. 

Figure 40. The Properties dialog box for Inner Ring

4  On the Attribute tab enter Inner in the Name field and 
ensure that the Material assigned is pec and click OK.
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Figure 41. Inner ring drawn

Complete the Ring
1  Click Edit>Select>By Name

The Select Object dialog box appears.

Figure 42. Select Object dialog box

2  Select Ring, press the Ctrl key and click Inner and click 
OK.

3  Click Modeler>Boolean>Subtract
The Subtract dialog box appears.

4  Verify Ring is in the Blank Parts and Inner in the Tool 
Parts and click OK.
Post subtraction, the structure should resemble the one in 
Figure 44.
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Figure 43. Subtract dialog box

Figure 44. The subtracted ring

Create Extension 1
1  Draw a box freehand.

The Properties dialog box appears.
2  On the Command tab edit the fields as shown in Figure 45.
3  On the Attribute tab enter the Name as Ring_Ext1, ensure 

that pec is selected from the Material drop-down and click 
OK.

Figure 45. Extension1 properties
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Figure 46. The Ring_Ext1 applied

Create Extension 2
1  Draw a box freehand.

The Properties dialog box appears.
2  Edit the fields as shown in Figure 47.

Figure 47. Properties dialog box for Ring_Ext2

3  On the Attribute tab enter the Name as Ring_Ext2 and 
click OK.
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Figure 48. Ring_Ext2 applied

Create Source 1
1  Draw the rectangle freehand.

The Properties dialog box appears.
2  Click OK to accept the current settings.
3  Double click CreateRectangle from the history tree.
4  Edit the fields in the Command dialog box as in Figure 49.

Figure 49. Command dialog box for Source1

5  Click Attribute and enter Name type as Source1 and click 
OK.

Create Source 2
1  Draw the rectangle freehand.

The Properties dialog box appears.
2  Click OK to close the dialog box.
3  Under Rectangle1, double click CreateRectangle from the 
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history tree.
4  Edit the fields as shown in Figure 50.

Figure 50. Command dialog box for Source2

5  Double-click Rectangle1 and enter Source2 in the Name 
field and click OK.

Group the Conductors
1  Click Edit>Select>By Name

2  In the Select Object dialog box, select the Ring, 
Ring_Ext1, Ring_Ext2

3  Click OK.
4  Click Modeler>Boolean>Unite
5  Do Ctrl+D to fit the view.

Assign Excitation for Source1
We will use wave ports to excite source1:
1  Click Source1 from the history tree.

Source1 gets highlighted in the structure.
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Figure 51. Reference Conductor Terminal dialog box

2  Right click Source1, and select Assign Exci-
tation>Assign>Lumped Port
Reference Conductor for Terminals dialog box appears.

3  Set the options as shown in Figure 51 and click OK.

Assign Excitation for Source2
To select the object Source2:
1  In the History tree, expand the Unassigned objects tree. 

2  Select Source2.

Figure 52. History Tree
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To assign lumped port excitation
1  Click HFSS>Excitations>Assign>Lumped Port

2  Enter 2 for the Port Name.
3  Set the rest of the options as in Figure 51 and click OK.

Show All
To show all objects do the following:
1  Click View>Visibility>Show All>All Views

2  Do Ctrl+D to fit the view.

Boundary Display (Optional)
Boundary display/solver view provides a snapshot of all 
boundaries in the model including ports and surface residing 
on the surrounding background object. It can be very useful 
for diagnosing problems with design setups.
1  Click HFSS>Boundary Display (Solver View)

The Solver View of Boundaries dialog box appears.
Note   HFSS identifies all the unique boundary conditions 
and ports to display where the boundaries are physically 
located in the model.

2  Select the boundaries you wish to view from the dialog box 
as shown in Figure 53.
The choices made here will show the boundaries in the 
Modeler field. See Figure 54.

Figure 53. Solver View of Boundaries dialog box
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Figure 54. Solver Boundaries selected

Note   If you double-click the fields under Color, you can 
change the color as you want from the palette that 
appears. The background is displayed as the outer 
boundary and the perfect conductors are displayed as the 
smetal boundary.
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4 Analyze Spiral Conductor

This chapter describes how to run the simulation and gen-
erate reports.

This chapter contains the following topics:
D Create Analysis Setup
D Add Frequency Sweep
D Model Validation
D Analyze the Model
D Solution Data
D Profile
D Convergence
D Matrix Data
D Mesh Statistics
D Generate Reports
D Create S-Parameter vs Frequency Plot
D Custom Equations – Output Variables
D Use Output Variables for Next Report
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Create Analysis Setup
To create an analysis setup:
1  Click HFSS>Analysis Setup>Add Solution Setup

The Add Solution Set-up dialog box appears.

Figure 1. Solution Set-up window.

2  In the Solution Setup window: click the General tab.
3  Edit the fields as shown in Figure 1. 
4  Click Options, edit the fields as in Figure 2 and click OK.
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Figure 2. Options tab

Add a Frequency Sweep
1  Click HFSS>Analysis Setup>Add Sweep

The Edit Frequency Sweep dialog box appears.
2  Enter the following fields as shown in Figure 3.

Figure 3. Edit Frequency Sweep
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3  Click the Interpolation tab and edit the fields as in Figure 
4 and click OK.

Figure 4. Interpolation

Model Validation
Before running the simulation your model must pass the Vali-
dation Check.
To validate the model:
1  Click HFSS>Validation Check

Figure 5. Validation Check

2  Verify whether your dialog box is the same as Figure 5.
3  Click Close.
Note: For this project, ignore warnings as no action is 
required.
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Analyze the Model
To start the solution process:
1  Click HFSS>Analyze All

Note   Change the design name to No_Solve_Inside(Driven 
Terminal) and then, save the project si_spiral_inductor. 

Review Solution Data
To view the Solution Data:
1  Click HFSS>Results>Solution Data

2  Click Profile, Convergence, Matrix Data etc to see those 
panels and the results they contain.

Review the Profile Panel
The Profile window lets you view a synopsis of the simulation
results ranging from mesh creation and refinement to infor-
mation about the different adaptive passes, the matrix
assembly and solve along with extraction of electromagnetic
field and SYZ parameter data. The more highly refined the 
mesh, i.e. higher the number of tetrahedra, more accurate is 
HFSS’ solution of the design generating optimum results. 
However, there is a trade-off in the number of tetrahedra 
used and the computational resources required. Higher the 
number of tetrahedra the more accurate the solutions. Keep 
in mind that increased accuracy requires more computational 
resources and more time.
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Figure 6. Profile

Review the Convergence Panel
To view the Convergence data click the Convergence tab.
Note: The default view is for convergence is Table. Select the 
Plot radio button to view a graphical representations of the 
convergence data.

Figure 7. Convergence dialog box
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Review the Matrix Data Panel
To view matrices computed for the S-parameters, imped-
ances, and propagation constants during each adaptive, non-
adaptive, or sweep solution, click the Matrix Data tab.

Figure 8. Matrix Data 

Note: To view a real-time update of the Matrix Data, set 
the Simulation to Setup1, Last Adaptive.

Review the Mesh Statistics Panel
As the title indicates this panel shows statistics of the mesh, 
more specifically, it gives break-ups of the tetrahedra used to 
solve the different components of the model and their size 
and data.

Figure 9. Mesh Statistics

Generate Reports
The subsequent sections describe how to create different 
reports, customize the equations for the Y axis and create 
output variables.

Create S-parameter vs. Frequency Plot
1  Click HFSS>Results>Create Terminal Solution Data 
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Report>Rectangular Plot

The Report dialog box appears.

Figure 10. Report dialog box

2  Edit the fields as shown in Figure 10.
3  Click New Report and Click Close.

Figure 11. The XY Plot
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Custom Equations – Output Variables
1  Click HFSS>Results>Create Terminal Solution Data 

Report>Rectangular Plot

The New Report dialog box appears.
2  Click Output Variables.

Figure 12. Output Variables dialog box

3  Enter Q11 in the Name field.
4  Select Terminal Y Parameters from Category.
5  Select Yt(Source1_T1, Source1_T1) as Quantity.
6  Select im from the Function list.
7  Click Insert Quantity into Expression.
8  Type the forward slash(/).
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Figure 13. Expression
Note   Notice the expression is in red ink because it is 
incomplete. The slash causes HFSS to expect another 
function. Red ink indicates inaccuracy or incompleteness.

9  Select Yt(Source1_T1, Source1_T1) in the Quantity field.
10  Select Function: re
11  Click Insert Quantity into Expression.
12  Click Add.

The output variable Q11 is added to the list.
13  Create Q22 with Yt(Source2_T1, Source2_T1) as quan-

tity.
14  Click Add.

.

Figure 14. Output Variables set

15  Click Done.
The Output Variables dialog box closes.

16  Edit the fields in the Report dialog box as in Figure 15.
17  Click New Reports and click Close.
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Figure 15. Report dialog box

Figure 16. Y parameters versus Frequency

Use Output Variables for Next Report
To use Output Variables for another report:
1  Click HFSS>Results>Create Terminal Solution Data 

Report>Rectangular Plot

2  In the New Report window, Trace Tab click the Output 
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Variables button
3  In the Output Variables dialog box enter these values:

• Name: L11
• Type -1/(2*pi*freq* in the Expression field.
• Select Terminal Y Parameters from Category.
• Select Yt(Source1_T1, Source1_T1) from Quantity.
• Click im from the Function list.

4  Click Insert into Expression.
5  Type a bracket “)” key and click Add.

Figure 17. New Report dialog box

Figure 18. Output Variables dialog box

6  Click Done to close the Output Variables dialog box.
7  Edit the fields in Report dialog box as shown in Figure 19.
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Figure 19. Report dialog box

8  Click New Report and click Close.
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Figure 20. L11 versus Frequency

Simulate with Solve Inside Conductors
In this section, we will select simulate the design with Solve 
Inside selected for the spiral. By default Solve Inside gets 
unchecked for metals or highly conductive materials. In such 
cases, the conductive material is represented by a boundary 
condition that removes the need to solve inside the metal. 
For most projects, we recommend that you use the default 
settings for Solve Inside. When Solve Inside is selected it 
includes tetrahedra inside a conductor for simulation which 
may require a large mesh. Solve Inside can be useful for low 
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frequency analysis of electrically small projects for enhanced 
accuracy of sensitivity design parameters such as the Q factor.
1  In the Project Manager window select the design and copy 

it.

Figure 21. 
2  Go the project folder and paste the design.

Figure 22. 
3  Rename the pasted design.

Figure 23. 
4  Double-click spiral from the history tree and select Solve 

Inside in the Attribute dialog box.
The Message Manager displays the following message: 
Solving inside a solid with high conductivity may require a 
large mesh. 
Note   For this project, ignore this message.

5  Right click the design and select Analyze All from the 
short-cut menu.
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Figure 24. 

Results With Solve Inside
All the plots get updated real time as the simulation takes 
place. For this design it may take more passes to converge 
than when Solve Inside was unchecked.

Figure 25. Convergence Plot
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Figure 26. 
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Figure 27. 
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Figure 28. 
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