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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in this 
guide.

• Procedures are presented as numbered lists. A single bullet indicates that the procedure has only 
one step.
Bold type is used for the following:
- Keyboard entries that should be typed in their entirety exactly as shown. For example, “copy 

file1” means the word copy must be typed, then a space must be typed, and then file1 must 
be typed.

- On-screen prompts and messages, names of options and text boxes, and menu commands. 
Menu commands are often separated by carats. For example, “click HFSS>Exci-
tations>Assign>Wave Port.”

- Labeled keys on the computer keyboard. For example, “Press Enter” means to press the key 
labeled Enter.

• Italic type is used for the following:
- Emphasis.
- The titles of publications.
- Keyboard entries when a name or a variable must be typed in place of the words in italics. For 

example, “copy file name” the word copy must be typed, then a space must be typed, and 
then name of the file must be typed.

• The plus sign (+) is used between keyboard keys to indicate that you should press the keys at the 
same time. For example, “Press Shift+F1” means to press the Shift key and the F1 key at the 
same time.

• Toolbar buttons serve as shortcuts for executing commands. Toolbar buttons are displayed after 
the command they execute. For example,

• “On the Draw menu, click Line ” means that you can click the Draw Line toolbar button to 
execute the Line command.
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Getting Help: ANSYS Technical Support

For information about ANSYS Technical Support, go to the ANSYS corporate Support website, 
www.ansys.com/Support. You can also contact your ANSYS account manager in order to obtain this 
information.

All ANSYS�(0 software files are ASCII text and can be sent conveniently by e-mail. When reporting 
difficulties, it is extremely helpful to include very specific information about what steps were taken or 
what stages the simulation reached, including software files as applicable. This allows more rapid and 
effective debugging.

Help Menu

To access online help from the HFSS menu bar, click Help and select from the menu:

Contents - click here to open the contents of the online help.

Search - click here to open the search function of the online help.

Index - click here to open the index of the online help.

Context-Sensitive Help

To access online help from the HFSS user interface, do one of the following:

• To open a help topic about a specific HFSS menu command, press Shift+F1, and then click the
command or toolbar icon.

• To open a help topic about a specific HFSS dialog box, open the dialog box, and then press F1.

www.ansys.com/Support
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1 Introduction

This document is intended as supplementary material to 
HFSS for beginners and advanced users. It includes 
instructions to create, simulate, and analyze a dielectric 
resonator antenna.
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What You Will Learn
By following the steps in this guide, you will learn how to 
perform the following tasks in HFSS:
D�Draw a geometric model.
D�Modify a model’s design parameters.
D�Assign variables to a model’s design parameters.
D�Specify solution settings for a design.
D�Validate a design’s setup. 
D�Run an HFSS simulation.
D�Create a 2D x-y plot of S-parameter results.
D�Create a field overlay plot of results.
D�Create a phase animation of results.

Sample Project - Dielectric Resonator Antenna
In this project you will learn to setup, solve, and analyze a 
dielectric resonator antenna. The antenna is cavity-backed 
with an annular-slot-fed hemispherical dielectric resonator. 
The antenna feed is achieved by coaxial excitation across one 
side of an annular slot between the cavity and the DRA dielec-
tric. For this project, the engineering focus is on the behavior 
of the antenna itself, not its feed. Therefore, the model will 
feed with a lumped port across an annular slot. The design’s 
operating frequency will be 3.5 GHz. 

Note   This project is also described and analyzed in the following IEEE publication: 
Leung, K.W., So, K.K., “Annular-slot-Excited Dielectric Resonator Antenna with a 
Backing Cavity,” IEEE Transactions on Antennas and Propagation, August 2002. 

A Dielectric Resonator Antenna designed on HFSS is illustrated 
in Figure 1.
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Figure 1. Sample Project - Dielectric Resonator Antenna
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Finite Element Method
The geometry for the dielectric resonator antenna problem 
(DRA) described in this document appears below. The antenna 
is cavity-backed with an annular-slot-fed hemispherical 
dielectric resonator. The antenna feed is achieved by coaxial 
excitation across one side of an annular slot between the cav-
ity and the DRA dielectric.
In HFSS, the model automatically gets divided into a large 
number of tetrahedra, where a single tetrahedron is a four-
sided pyramid. This collection of tetrahedra is referred to as 
the finite element mesh. Figure 2 shows the mesh created for 
the dielectric resonator antenna.

Figure 2. The Mesh that Constitutes the Antenna
Dividing a structure into thousands of smaller regions (ele-
ments) allows the system to compute the field solution sepa-
rately in each element. The smaller the system makes the 
elements, the more accurate the final solution will be.
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2 Create the New Project

This chapter contains the following topics:
D Overview of the Interface
D Launch HFSS and Set-up the Project
D Set the Units Of Measurement
D Verify HFSS and Modeler Options
D Select the Solution Type
D Set the Co-ordinate System
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Overview of the Interface
An overview of the major components of HFSS14’s interface is 
in the Figure below.

Figure 3. Overview of HFSS GUI
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The different options on the GUI are described as follows:

Project Manager 
window

Displays details about all open HFSS projects. 
Each project has its own project tree, which 
ultimately includes a geometric model and its 
boundaries and excitations, material 
assignments, analysis setups, and analysis 
results. 

Message Manager 
window

Displays error, informational, and warning 
messages for the active project.

Progress window Displays solution progress information.

Properties window Displays the attributes of a selected object in 
the active model, such as the object’s name, 
material assignment, orientation, color, and 
transparency. Also displays information about a 
selected command that has been carried out. 
For example, if a circle was drawn, its command 
information would include the command’s 
name, the type of coordinate system in which it 
was drawn, the circle’s center position 
coordinates, the axis about which the circle was 
drawn, and the size of its radius.

3D Modeler 
window

Displays the drawing area of the active model, 
along with the history tree.

History tree Displays all operations and commands carried 
out on the active model, such as information 
about the model’s objects and all actions 
associated with each object, and coordinate 
system information. 
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Launch HFSS and Set-up the Project
You must launch HFSS and set up a project to design a Dielec-
tric Resonator Antenna. As part of setting up the project you 
must perform the following tasks:

• Launch HFSS
• Open and Save a New Project
• Set the Units of Measurement
• Verify HFSS Options
• Select Solution Type

This section shows you how to accomplish the above tasks.
Note   We recommend you store a shortcut of the HFSS application on your desktop.

1  Double-click the HFSS 14 icon on your desktop.

HFSS opens with a new project listed on its Project Man-
ager window. See Figure 2.

Menu bar Provides various menus that enable you to 
perform all of the HFSS tasks, such as managing 
project files, customizing the desktop 
components, drawing objects, and setting and 
modifying all project parameters.

Toolbars Provides buttons that act as shortcuts for 
executing various commands.

Status bar Shows current actions and provides instructions. 
Also, depending on the command being carried 
out, the status bar can display the X, Y, and Z 
coordinate boxes, the Absolute/Relative pull-
down list to enter a point’s absolute or relative 
coordinates, a pull-down list to specify a point 
in cartesian, cylindrical, or spherical 
coordinates, and the active model’s unit setting. 
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Figure 4. Project Manager Window
Note   If a project is not listed in the project tree, go to File and click New to include 
one; and if the Project Manager window does not appear after launching the 
application, go to View and enable it.

2  Expand the project tree to see if the “Insert HFSS Design” 
option is present and do one of the following steps:
a. If the option is present, go to step 3.
b. If absent, on the toolbar click Project and select “Insert HFSS 

Design.”
HFSSDesignn appears in the Project tree. See Figure 3.

Figure 5. HFSS Designn included
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Note   A new project is listed in the project tree in the Project Manager window with 
the default label Projectn. Definitions and Materials are stored under the project 
name.

3  Right click HFSSDesignn, click Rename on the shortcut 
menu, type Dielectric Resonator Antenna and hit Enter.
The design is renamed as DielectricResonatorAntenna.

4  Click File>Save As.
The Save As dialog box appears.

5  Browse for a location to store the file (such as C:\Program 
Files\Ansoft\HFSS14.0\Projects) and then, double-click the 
folder’s name.

6  Type dr_antenna in the File name text box, and then, 
click Save.

The project is saved in the folder you selected to the file 
name dr_antenna.hfss.

Set the Units of Measurement
You must set the units of measurement for drawing the geo-
metric model (UHF Probe) as follows:
1  On the HFSS toolbar, click Modeler>Units.

The Set Model Units dialog box appears.

Figure 6. Set Model Units dialog box

Select mm (millimeters) from the Select units drop-down 
menu, and click OK.

Verify HFSS and Modeler Options
Certain options under the Tools drop-down menu have to be 
verified before you create the design model.
1  Click Tools>Options>HFSS Options.

The HFSS Options dialog box opens.
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Figure 7. Assignment Options

2  Click the General tab.
3  Verify whether the Assignment Options are checked. See 

Figure 5.
4  Click OK to close the dialog box.
5  Click Tools>Options>Modeler Options.

The Modeler Options dialog box opens.
6  Click Operation.
7   Check “Automatically cover closed polylines.”
8  Click the Drawing tab.
9  Check “Edit property of new primitives.” 

This will cause a Properties dialog box to open when you 
create a new primitive object in the Modeler.

10  Click OK.

Select the Solution Type
To set the solution type:
1  Click HFSS>Solution Type on the toolbar.

The Solution Type dialog box opens.



Getting Started with HFSS: A Dielectric Resonator Antenna

2-8 Create the New Project 
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Figure 8. Solution Type dialog box

2  Select Driven Modal.
Note   This antenna project is a mode-based problem so 
select the Driven Modal option.

3  Click OK.
Now, you are ready to draw the objects for the antenna 
problem. 

Set the Co-ordinate System
For this antenna problem, you will use the fixed, default 
global coordinate system (CS) as the working CS. HFSS has 
three types of coordinate systems that let you easily orient 
new objects. They are described below.

Global CS The fixed, default CS for each new 
project.

Relative CS A user-defined CS. Its origin and 
orientation can be set relative to the 
global CS, relative to another Relative CS, 
or relative to a geometric feature. 
Relative CSs enable you to easily draw 
objects that are located relative to other 
objects.

Face CS A user-defined CS. Its origin is specified on 
a planar object face. Face CSs enable you 
to easily draw objects that are located 
relative to an object’s face.
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Grid Settings
The grid displayed in the 3D Modeler window is a drawing aid 
to visualize the location of objects. The points on the grid are 
divided by their local x-, y-, and z-coordinates and grid spac-
ing is set according to the current project’s drawing units.
For this antenna project, it is not necessary to edit any of the 
grid’s default properties. 

Note   To edit the grid’s properties, click Grid Settings on the View menu to control 
the grid’s type (cartesian or polar), style (dots or lines), density, spacing, or visibility.
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3 Draw the Model

This chapter contains the following topics:
D Overview of the Interface
D Launch HFSS and Set-up the Project
D Set the Units Of Measurement
D Verify HFSS and Modeler Options
D Select the Solution Type
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Create the DRA Geometry
The geometry for this dielectric resonator antenna (DRA) 
model consists of five basic objects as follows:

Create the Spherical Cavity 
You will first draw the antenna’s spherical cavity. To this end, 
you will draw a sphere first and then, split it to form a hemi-
spherical solid. 
1  Click Draw>Sphere. 

2  Draw a sphere with origin as center and radius=25mm.
The Properties dialog box appears.

Figure 9. Sphere Properties

3  Enter the fields in the dialog box so that they are the same 
as what you see in Figure 1.
The sphere appears in the drawing region. 

4  Press Ctrl+D to fit the sphere in the drawing region.
The sphere must resemble the one shown in Figure 2.

5  Click Attribute and type cavity in the Name field.
6  Click OK.

The Properties dialog box disappears.
7  Select cavity from History Tree to highlight the sphere.

Air volume 30 mm radius and a height of 35 mm

Spherical Cavity 25 mm radius

Spherical DRA 12.5 mm radius

Annular ring 5.8 mm outer radius and a width of 1.0 
mm. 

Feed gap 1mm thickness



Getting Started with HFSS: A Dielectric Resonator Antenna

Draw the Model 3-3
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Figure 10. Sphere in the 3-D Modeler window

8  Click Modeler>Boolean>Split. 
The Split dialog box appears. 

Figure 11. Split dialog box
9  Enter the following settings:

• Split plane = XY.
• Keep Fragments = Negative side

• Split objects = Split entire selection

10  Click OK.
The object cavity is split into a hemispherical solid.
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Figure 12. Cavity

Modify Cavity Attributes
1  Doble-click cavity on the History Tree.

The Attribute tab opens.

Figure 13. Cavity Attributes

2  Click Edit in the Color row. 
The Color palette appears. 
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Figure 14. Color Pallette
3  Select red.
4  Enter 255, 0, 0 in the RGB settings as shown in Figure 6.
5  Click button 0 in the Transparency row. 

The Set Transparency window appears. 

Figure 15. Set Transparency dialog box

6  Enter .07 for the value of Transparency. 
The Transparency is now set to .07. 

7  Select “vacuum” as the material.
8  Click outside the object, on the grid background, to dese-

lect cavity.
The object updates with the attributes that you set.
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Verify Lighting Attributes
1  Click View>Modify Attributes>Lighting. 

The Lighting Properties dialog box appears. 

Figure 16. Lighting Properties dialog box

2  Verify that the Do not use lighting option is unchecked. 
3  Click OK.

Your completed object cavity should resemble the one 
shown below:
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Figure 17. The cavity with the latest attributes applied

Draw the Dielectric Resonator
Now, you will draw another sphere, split it, and then edit its 
Attributes.
1  Click Draw>Sphere.

2  Draw a sphere with center at origin and radius=12.5 mm.

Figure 18. Properties for dra
3  Enter the settings as shown in Figure 10.
4  Click Attribute and type dra in the Name field.
5  Click OK.

The sphere appears in the 3-D Modeler window.
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Figure 19. The dra object

6  Select dra to highlight it.
7  Click Modeler>Boolean>Split. 

The Split dialog box appears.

Figure 20. Split dialog box

8  Enter the following settings:

• Split plane = XY.
• Keep Fragments =Positive side
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• Split objects = Split entire selection

9  Click OK.
The object dra is split into a hemispherical solid.

Figure 21. dra split.

Modify DRA Attributes
1  Double-click dra on the History Tree.

The Attribute dialog box appears.
2  Click Edit in the Color row. 
3  Select yellow.
4  Set RGB to 255, 255, 0 from the Color palette, and then 

click OK. See Figure 14.
5  Change Transparency to 0.07.

6  Click Edit from the Material pull-down menu (Figure 15).
The Select Definitions dialog box appears. See Figure 16.

7  Click Add Material.
The View/Edit Material dialog box appears. See Figure 17.

8  Enter Material Name as dra_diel.
9  Enter Value as 9.5.
10  Click OK.

View Edit/Material dialog box closes and Select Defini-
tions dialog box gets updated with the new entry.
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11  Click OK on the Select Definitions dialog box.
The Attributes dialog box gets updated with dra_diel in 
the Material field. See Figure 19.

12  Click OK.

Figure 22. Color Palette

Figure 23. dra Attributes 
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Figure 24. Select Definition dialog box

Figure 25. View/Edit Material dialog box

Figure 26. Updated Select Definitions



Getting Started with HFSS: A Dielectric Resonator Antenna

3-12 Draw the Model 
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Figure 27. Updated Attributes tab

Figure 28. Current Structure

Create the Annular Feed Ring
In this antenna model, the annular feed ring is the controlled 
aperture through which the E-fields will radiate. Later on in 
the project, you will assign a perfect H boundary to the annu-
lar feed ring to allow the E-fields to radiate through it. In this 
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section, you will create the antenna’s annular feed ring, 
which is the result of subtracting one circle from another.

Draw Circle1

1  Click Draw>Circle.

2  Enter (0, 0, 0) in the status bar fields for the position of 
the circle.

3  Press Enter.
4  Enter dX=4.8 as the radius. 
5  Press Enter.

The Properties dialog box appears and Circle1 appears in 
the model.
Note   You can even draw the circle free hand, click the 
corresponding CreateCircle option from the history tree 
and enter the position as (0,0,0) and radius as 4.8mm in 
the Properties dialog box that will show up. However, this 
is a roundabout way of drawing the circle, which can be 
accomplished by simply entering the dimensions in the 
status bar as shown above. 

Draw Circle2
In this section, we will discuss drawing the circle freehand.
1  Click Draw>Circle.

2  Draw the circle at any arbritrary location.
The Properties dialog box appears with the fields sup-
pressed. 

Figure 29. Properties dialog box
The circle appears in the 3-D Modeler field.

3  Double-click CreateCircle under Circle2 in the History 
Tree. 
The Properties dialog box appears.

4  Change the values for the Center Position and Radius to 
(0, 0,0) and 5.8mm as shown in Figure 22.
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Figure 30. Circle2 Properties

Circle1 and Circle2 should now both appear in your 
model, as shown below:

Subtract Circle1 from Circle2
Subtracting Circle1 from Circle2 will result in an annular feed 
ring of 1 mm width.
1  Select Circle2 either by clicking it in the 3D Modeler win-

dow or clicking its name in the history tree. 

Note   Circle2 will be the blank object — the object from 
which subtraction will occur.

2  Press and hold down the Ctrl key to also select Circle1.
Note   Circle1 is the tool object—the object to be 
subtracted from the blank object. 

3  Verify whether the status bar indicates number of objects 
selected is two.

Cavity
DRA

Circle2
Circle1
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4  Click Modeler>Boolean>Subtract. 
The Subtract window appears:

Figure 31. Subtract dialog box

5  Verify that Circle1 is in the Tool Parts list and Circle2 is in 
the Blank Parts list. 

6  Click OK. 
Circle1 is subtracted from Circle2, resulting in a 1 mm 
wide flat annulus or ring.

Figure 32. Structure after subtraction

7  Double-click Circle2 from the history tree.
The Attribute dialog box appears. 

8  Type annular_rng to rename, and then press Enter to 
accept the new name. 

9  Click Edit in the Color row.
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10  Enter 0, 0, 128 as the RGB settings from the Color pal-
ette, and then click OK. 

11  Set Transparency to .09. 
12  Click OK.

The structure gets updated with the latest settings.
13  Deselect annular_rng to view the resulting color and 

transparency assignments.

Figure 33. annular_rng

Draw the Feed Gap 
Feed gap is the object through which the excitation is fed. 
1  Draw a Rectangle.

The rectangle is drawn and the Properties dialog box 
appears with suppressed command.

2  Click OK.
3  Double-click CreateRectangle from the History Tree.

The Command tab of the Properties dialog box appears.
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Figure 34. Rectangle properties

4  Click OK.
The Properties dialog box appears.

Figure 35. The Rectangle drawn

Intersect Rectangle and Annular Feed Ring
Next, you will intersect the rectangle and the annular feed 
ring to produce the antenna’s feed gap. 
1  Click Tools > Options > Modeler Options.

The 3D Modeler Options dialog box appears. 
2  Click the Operation tab. 
3  Under Clone, select Clone tool objects before intersect-

ing, and then click OK to activate. 

Rectangle
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Note   This option instructs HFSS to always keep a copy of 
the original objects that intersect the first object 
selected.

4  Select Rectangle1.
5  Press and hold down Ctrl and select annular_rng.
6  Click Modeler>Boolean>Intersect.

The feed gap is produced without deleting the annular slot 
it is intended to feed.

Figure 36. Feed gap drawn
7  Double-click Rectangle1.

The Attribute dialog box appears. 
8  Type gap to rename the rectangle.
9  Press Enter.
10  Click Edit in the Color row.

The Color Palette appears.
11  Select green and set RGB as 0, 255, 0. 
12  Set Transparency to 0.
13  Click OK.
14  Deselect gap to view the resulting color and transpar-

ency assignments.

Feed gap
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Create the Air Volume
To analyze radiation effects, you must create a virtual object 
that represents the radiation boundary. For this antenna 
model, you will create a radiation-transparent air volume sur-
face sufficiently far from the model. 
Next, you will draw a regular polyhedron with 18 segments to 
represent this virtual object. Finally, you will assign a radia-
tion boundary before you analyze. 

Draw the Polyhedron
1  Click Draw>Regular Polyhedron.

2  Draw the polyhedron freehand on the modeler window.
The Segment number dialog box appears.

Figure 37. Segment number dialog box

3  Set Number of Segments as 18.
The Properties dialog box appears.

Figure 38. Command tab for the Polyhedron
4  Enter the values as shown in Figure 30. 
5  Click Attribute and rename Polyhedron1 to airvol.
6  Press Enter.
7  Click Edit in the Color row and set RGB to 0, 255, 255.
8  Set Transparency to 0.01.
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9  Move the slider to the right in the Set Transparency win-
dow and stop at the 2nd mark to set the level at .01.

10  Set “vacuum” in the Material row.
11  Deselect airvol to view the resulting color and transpar-

ency assignments.
12  Save the project.

The completed airvol object appears .

Figure 39. Airvol

Split the Model for Symmetry
This model as constructed is symmetrical about the yz plane. 
Now,you will split the model along the yz plane for symmetry.

1  Click Edit>Select All to select all the objects of the 
model. 

2  Click Modeler>Boolean>Split.
The Split window appears. 
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Figure 40. Split dialog box
3  Select YZ as the split plane and Positive side as the keep 

fragments. 
4  Click OK to split the entire model.

Your final model should appear similar to the one shown 
below:

Figure 41. 
5  Save the project. 

You are now ready to assign ports and boundaries to your 
antenna model.
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4 Setting Up the Problem

Now that you created the geometry and assigned all mate-
rials for the antenna problem, you are ready to define its 
ports and boundaries.

This chapter contains the following topics:
D�Define the boundary conditions, such as the location of 

a radiation boundary and the symmetry plane.
D�Define the lumped port through which the signal (volt-

age) enters the antenna.
D�Verify that you correctly assigned the boundaries and 

excitations to the model.
Now you are ready to set up the problem.

This chapter contains the following topics:
D Overview of the Interface
D Launch HFSS and Set-up the Project
D Set the Units Of Measurement
D Verify HFSS and Modeler Options
D Select the Solution Type
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Set Up Boundaries and Excitations
You must define the boundary and excitation conditions that 
include the excitation signals entering the structure, the 
behavior of electric and magnetic fields at various surfaces in 
the model, and any special surface characteristics. 

Boundary Conditions
Boundaries specify the behavior of magnetic and electric 
fields at various surfaces. They can also be used to identify 
special surfaces — such as resistors — whose characteristics 
differ from the default.
The following four types of boundary conditions will be used 
for this antenna problem:

Radiation This type of boundary simulates an open problem 
that allows waves to radiate infinitely far into 
space, such as antenna designs. HFSS absorbs the 
wave at the radiation boundary, essentially 
ballooning the boundary infinitely far away from 
the structure. In this antenna model, the air volume 
object is defined as a radiation boundary.

Perfect E This type of boundary models a perfectly 
conducting surface in a structure, which forces the 
electric field to be normal to the surface. In this 
antenna model, the bottom face of the air volume 
object is defined as a perfect E boundary.

Perfect H This type of boundary forces the tangential 
component of the H-field to be the same on both 
sides of the boundary. In this antenna model, the 
annular feed ring is the aperture that is assigned 
this boundary. Because the aperture is defined as a 
perfect H boundary, the E-fields will radiate 
through it. If it was not defined as a perfect H 
boundary, the E-field would not radiate through and 
the signal would terminate at the aperture. 
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Excitation Conditions
Ports define surfaces exposed to non-existent materials (gen-
erally the background or materials defined to be perfect con-
ductors) through which excitation signals enter and leave the 
structure. One lumped port will be defined for this antenna 
problem. Lumped ports are similar to traditional wave ports, 
but can be located internally and have a complex user-
defined impedance. Lumped ports compute S-parameters 
directly at the port. A lumped port can be defined as a rect-
angle from the edge of the trace to the ground, as in this 
antenna problem, or as a traditional wave port. The default 
boundary is perfect H on all edges that do not come in con-
tact with the metal.

Assigning Boundaries
First, you will assign all boundary conditions to the model. 
For information on the types of boundaries you will assign, 
see “Boundary Conditions” on page 4-2.

Assign a Radiation Boundary to the Air Volume
The first boundary you will assign is a radiation boundary to 
the air volume object. 
Radiation boundary model surfaces represent open space. 
Energy is allowed to radiate from these boundaries instead of 
being contained within them. A radiation surface does not 
have to be spherical, but it must be exposed to the back-
ground, convex with regard to the radiation source, and 
located at least a quarter wavelength from the radiating 
source. In some cases the radiation boundary may be located 
closer than one-quarter wavelength, such as portions of the 
radiation boundary where little radiated energy is expected.

Symmetry In structures that have an electromagnetic plane of 
symmetry, such as this antenna model, the problem 
can be simplified by modeling only one-half of the 
model and identifying the exposed surface as a 
perfect H or perfect E boundary. For this antenna 
problem, a perfect H symmetry boundary is used.
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To assign a radiation boundary to the air volume object: 

1  Select airvolfrom the history tree.

2  Click HFSS>Boundaries>Assign>Radiation. 
The Radiation Boundary dialog box appears. 

3  Verify that Name = Rad1.
4  Click OK.

The radiation boundary gets applied.
Note   For this antenna problem, it is not necessary to edit 
any boundary’s visualization default settings. 

The resulting radiation boundary is applied to the object 
airvol and now appears as a subentry of Boundaries in the 
Project Tree.

Hint To edit a boundary’s visualization settings:
1. Click HFSS>Boundaries>Visualization if you want to 

show or hide boundaries. The Boundary Visualization 
Options window appears.

2. Clear the View Geometry, View Name, or View Vector 
check boxes of boundaries that you want to hide from 
view. Select the options you want to show in the 3D 
Modeler window.

3. Click OK to apply the new settings.
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Figure 42. 

Assign a Perfect E Boundary to the Air Volume
Next, define the intersection between the cavity and the air 
volume as a perfect E boundary condition. Therefore, you will 
assign a perfect E boundary to the bottom face of the air vol-
ume object, which will be the ground plane of the antenna. 
By default, all HFSS model surfaces exposed to the back-
ground are assumed to have perfect E boundaries; HFSS 
assumes that the entire structure is surrounded by perfectly 
conducting walls. The electric field is assumed to be normal 
to these surfaces. The final field solution must match the case 
in which the tangential component of the electric field goes 
to zero at perfect E boundaries.
The surfaces of all model objects that have been assigned 
perfectly conducting materials are automatically assigned 
perfect E boundaries.

Radiation 
boundary 
added as a 
subentry of 
Boundaries.

Radiation boundary 
applied to the air 
volume object.

Properties of 
the Radiation 
boundary
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To assign a perfect E boundary to the bottom face of the air 
volume object:
1  Deselect the radiation boundary you just assigned.

2  Hit F on the keyboard to enter Face Selection mode.
3  Select the bottom face of the object airvol as follows: 

• Press and hold down Alt and drag the mouse to rotate 
the model to a position where you can click the bot-
tom face of the object airvol.

• Select the back face where the polyhedron was split.
• Hit B and the bottom face will get selected.

Figure 43. The bottom face selected

4  Click HFSS>Boundaries>Assign>Perfect E.
The Perfect E Boundary dialog box appears. 

5  Uncheck Infinite Ground Plane. 
Note   If selected, the option simulates the effects of an 
infinite ground plane. It only affects the calculation of 
near- and far-field radiation during post processing. The 
3D Post Processor models the boundary as a finite portion 
of an infinite, perfectly conducting plane.
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Figure 44. Perfect E Boundary

6  Click OK.
The perfect E boundary is applied. 
The resulting perfect E boundary condition is assigned to 
the bottom face of the object airvol.

Figure 45. Perfect E-boundary applied

Assign a Perfect H to the Annular Feed Ring 
The next boundary you will assign is a perfect H on the annu-
lar ring portion of the perfect E you just assigned to the bot-
tom face of the air volume object. This perfect H boundary 
assignment will supersede the annular ring area from the 
prior Perfect E definition.
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A perfect H boundary represents a surface on which the tan-
gential component of the H-field is the same on both sides. 
For internal planes, such as the annular ring in this antenna 
model, this results in a natural boundary through which the 
field propagates. For planes on the outer surface of the 
model, this results in a boundary that simulates a perfect 
magnetic conductor in which the tangential component of the 
H-field is zero.
To assign a perfect H boundary to the face of annular ring: 
1  Deselect the perfect E boundary you just assigned, if it is 

still selected.

2  Hit F to enter Face Selection mode.
3  Click annular_rng on the History tree.
4  Click HFSS>Boundaries>Assign>Perfect H. 

The Perfect H Boundary dialog box appears.
5  Click OK.

The perfect H boundary gets assigned.

Figure 46. Perfect H Boundary assigned
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Assign a Symmetry Boundary to the Model
HFSS has a boundary condition specifically for symmetry 
planes. Instead of defining a perfect E or perfect H boundary, 
you define a perfect E or perfect H symmetry plane. 
When you are defining a symmetry plane, you must decide 
which type of symmetry boundary should be used, a perfect E 
or a perfect H. In general, use the following guidelines to 
decide which type of symmetry plane to use: 
•    If the symmetry is such that the E-field is normal to the 

symmetry plane, use a perfect E symmetry plane. 
•    If the symmetry is such that the E-field is tangential to the 

symmetry plane, use a perfect H symmetry plane.
The simple two-port rectangular waveguide shown below 
illustrates the differences between the two types of symme-
try planes. The E-field of the dominant mode signal (TE10) is 
shown. The waveguide has two planes of symmetry, one verti-
cally through the center and one horizontally.
•    The horizontal plane of symmetry is a perfect E surface. 

The E-field is normal and the H-field is tangential to that 
surface.

•    The vertical plane of symmetry is a perfect H surface. The 
E-field is tangential and H-field is normal to that surface.

Figure 47. Field and Symmetry planes

Since the antenna model in this guide has a vertical plane of 
symmetry and the E-field is tangential to the surface, use a 
perfect H boundary for the symmetry plane. 

Electric field of TE10 Mode

Perfect E symmetry plane

Perfect H symmetry plane
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Next, you will assign a perfect H symmetry boundary to the 
symmetry cut faces of the objects airvol and cavity (the 
model’s symmetry plane).
To assign a perfect H symmetry boundary to the model’s sym-
metry plane: 
1  Deselect the perfect H boundary you just assigned.

2  Hit F to enter face selection mode.
3  Click airvol and cavity from the History Tree.
4  Rotate the model and select the symmetry cut faces as 

shown in Figure 7. 

Figure 48. Symmtery cut faces selected.

5  Click HFSS>Boundaries>Assign>Symmetry. 
The Symmetry Boundary dialog box appears. 

6  Verify that the default name is Sym1.
7  Select Perfect H as the symmetry type, and click OK.

The resulting perfect H symmetry boundary condition is 
assigned to the faces of the objects airvol and cavity, as 
shown below:
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Figure 49. Symmetry boundary applied
Note   At this juncture, you have finished assigning the 
boundaries and it is a good idea to save your project. 

Assigning Excitations
You will now assign all excitation conditions to the model.

Assign a Lumped Port Across the Gap
For this antenna problem, the engineering focus is on the 
behavior of the antenna itself, not its feed. Therefore, the 
model will feed with a lumped port across the annular slot, or 
gap object. Lumped ports are similar to traditional wave 
ports, but can be located internally and have a complex user-
defined impedance. Lumped ports compute S-parameters 
directly at the port. A lumped port can be defined as a rect-
angle from the edge of the trace to the ground, as in this 
antenna problem, or as a traditional wave port. The default 
boundary is perfect H on all edges that do not come in con-
tact with the metal. 

Note   The setup of a lumped port varies slightly depending on whether the solution is 
modal or terminal. As a reminder, the solution type for this antenna problem is modal 
driven.
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To assign a lumped port across the gap object:
1  Deselect the perfect H symmetry boundary.

2  Click gap from the History Tree to select it. See Figure 9.
Note   Recall gap is the rectangle you renamed. You should 
look under Unassigned.

3  Click View>Interaction>Zoom In to zoom in on the area 
where the gap object is located. 

Figure 50. The gap is selected

4  Click HFSS>Excitations>Assign>Lumped Port. 
The Lumped Port dialog box appears.

Figure 51. Lumped Port: General dialog box
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Note   The first time you assign a lumped port, HFSS walks 
you through the process with a step-by-step wizard.

5  Enter the values as shown in Figure 10.
6  Click Next.
7  In the Lumped Port:Modes step, click in the Integration 

Line list, and then select New Line. 
The cursor changes to a dotted line and the Measure Data 
and Create Line dialog boxes appear.

Figure 52. Measure Data for the first point of the Integration Line.

8  Click the start point (0, 5.8, 0) as shown in Figure 11.
Note   Use the Meassure Data dialog box as reference as 
you move your cursor to reach (0, 5.8, 0).

9  Click the end point (0, 4.8, 0) as shown in Figure 12.
The Lumped Port dialog box appears.

Figure 53. 

Note   The endpoint defines the direction and length of 
the integration line. 

10  Click Next.
The Post Processing dialog box appears.
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11  Enter 100 ohm for Full Port Impedance and click Finish.
The lumped port assignment is completed.
The resulting lumped port is assigned across the object 
gap, as shown below:

Figure 54. Lumped Port assigned

Modify the Impedance Multiplier
Because you defined a symmetry plane (allowing the model of 
a structure to be cut in half), the impedance computations 
must be adjusted by specifying an impedance multiplier.
In cases such as this antenna problem, where a perfect H 
plane of symmetry splits a structure in two, only one-half of 
the power flow is seen by the system but the full voltage dif-
ferential is present. Therefore, structures split in half with 
perfect H symmetry planes result in computed impedances 
that are twice those for the full structure. An impedance mul-
tiplier of 0.5 must be specified in such cases.

Integration line

Gap

Annular feed 
ring



Getting Started with HFSS: A Dielectric Resonator Antenna

Setting Up the Problem 4-15
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

To edit the impedance multiplier:
1  Click HFSS>Excitations>Edit Port Impedance Multiplier.

The Edit Port Impedance Multiplier dialog box appears.

2  Enter 0.5 in the Impedance Multiplier box.
3  Click OK. 
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Verify All Boundary and Excitation Assignments
Now that you have assigned all the necessary boundaries and 
excitations to the model, you should review their specific 
locations on the model in the solver view. 
When you verify boundaries and excitations in the solver view, 
you review the locations of the boundaries and excitations as 
you have defined them for generating a solution (solving). 
HFSS runs an initial mesh and determines the locations of the 
boundaries and excitations on the model. 
Then, you can select a boundary or excitation from the 
Boundaries list in the Project window to view its highlighted 
area in the model. 
To check the solver’s view of boundaries and excitations: 
1  Click HFSS>Boundary Display (Solver View). 

HFSS runs an initial mesh and determines the locations of 
the boundaries and excitations on the model. 
The Solver View of Boundaries window appears, which 
lists all the boundaries and excitations for the active 
model in the order in which they were assigned. 

Figure 55. Solver View of Boundaries dialog box

2  Select a check box in the Visibility column that corre-
sponds with the boundary or excitaton for which you want 
to review its location on the model. 
Note   For example, Visibility is selected for PerfE1 and 
Sym1 and they will appear in the model in the color it has 
been assigned, as indicated in the Color column.
• Visible to Solver will appear in the Solver Visibility 

column for each boundary that is valid. 
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• Overridden will appear in the Solver Visibility column 
for each boundary or excitation that overwrites any 
existing boundary or excitation with which it overlaps.

Figure 56. PerfE1 and Sym1 boundaries selected

3  Verify that the boundaries or excitations you assigned to 
the model are being displayed as you intended for solving 
purposes. See Figure 15.

4  Modify the parameters for those boundaries or excitations 
that are not being displayed as you intended. 

5  Click Close, and then click File>Save, or click the Save a 
project button on the toolbar, to save the geometry.

You are now ready to set up the solution parameters for this 
antenna problem and generate a solution.
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5 Generating a Solution

Now that you have created the geometry and set up the 
model, you are ready to generate a solution.
Your goals for this chapter are to:
D�Set up the solution parameters that will be used in cal-

culating the solution.
D�Define meshing instructions.
D�Validate the project setup. 
D�Generate a solution. 
D�View the solution data, such as convergence and 

matrix data information.
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Add Solution Set-up
Now, you will specify how HFSS will compute the solution by 
adding a solution setup to the antenna project’s design. 
To add a solution setup to the design: 
1  Click HFSS>Analysis>Add Solution Setup.

The Solution Setup dialog box appears: 

Figure 57. Solution Set-up

2  Click the General tab and enter values in the fields as 
shown in Figure1.

3  Click Options.
4  Set the fields as shown in Figure 2.
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Figure 58. Options dialog box

5  Click OK. 
Setup1 now appears as a solution setup under Analysis in 
the project tree. 

Figure 59. Project Tree

Add a Frequency Sweep to the Solution Setup
To generate a solution across a range of frequencies, add a 
frequency sweep to the solution setup. HFSS performs the 
sweep after the adaptive solution.
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For this antenna model, you will add a Fast frequency sweep 
to the solution setup. A Fast sweep generates a unique full-
field solution for each division within a frequency range. It is 
best for models that will abruptly resonate or change opera-
tion in the frequency band, and obtains an accurate represen-
tation of the behavior near the resonance.
To add a fast frequency sweep:
1  Click HFSS>Analysis Setup>Add Sweep.

The Select window appears. 
2  Select Setup1 for the solution setup to which the sweep 

applies, and click OK.
The Edit Sweep dialog box appears.

Figure 60. Edit Frequency Sweep

3  Enter the settings as shown in Figure 4.
Note   If you do not save the field solution, the associated 
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mode will not be available as a source stimulation during 
post processing.

4  Click OK.
Sweep1 now appears as a frequency sweep under Setup1 
in the project tree.
Note   Click Display if you want to display each of the 
sweep values at the 0.01 GHz step size increment within 
the frequency range you specified. 

Define Mesh Operations
In HFSS, mesh operations are optional mesh refinement set-
tings that are specified before a mesh is generated. The tech-
nique of providing HFSS with mesh construction guidance is 
referred to as “seeding” the mesh. 
Since the fields in the annular feed ring are very important in 
this antenna model, you will provide some meshing instruc-
tions on the faces of this object. 
You will assign a length-based mesh refinement to the faces of 
the annular feed ring. Requesting length-based mesh refine-
ment instructs HFSS to refine the length of tetrahedral ele-
ments until they are below a specified value. The length of a 
tetrahedron is defined as the length of its longest edge.
You specify the maximum length of tetrahedra on faces or 
inside of objects. You can also specify the maximum number 
of elements that are added during the refinement. When the 
mesh is generated, the refinement criteria you specified will 
be used.
To assign a length-based mesh refinement to all the faces of 
the annular feed ring: 
1  Select annular_rng from the History Tree.

You may need to expand the hierarchy under Sheets, then 
again under Perfect H to select the annular_rng.

2  On the HFSS menu, point to Mesh Operations>Assign>On 
Selection, and then click Length Based. 
Note   Applying the On Selection command refines every 
face on the annular feed ring. 
The Element Length Based Refinement dialog box 
appears.
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Figure 61. Element Length Based Refinement

3  Restrict the length of tetrahedra edges touching the faces:

• Select the Restrict Length of Elements check box.
• Enter 0.5 mm in the Maximum Length of Elements 

text box as the maximum length of the tetrahedral 
elements touching the faces.

Note   HFSS will refine the element edges touching the 
selected faces until they are equal to or less than this 
value.

4  Accept the default name Length1.
5  Clear Restrict the Number of Elements, if it is selected. 

Note   If selected, Restrict the Number of Elements 
restricts the number of elements added during refinement 
on the faces.

6  Click OK.
Length1 now appears as a mesh refinement under Mesh 
Operation in the project tree.
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Validate the Project Setup
Before you run an analysis on the antenna model, it is import-
ant to first perform a validation check on the project. HFSS 
runs a check on all the setup details of the active project to 
verify that all the necessary steps have been completed and 
their parameters are reasonable. 
To perform a validation check on the project dra_antenna: 
1  Click HFSS>Validation Check, or click the Validation 

Check button on the toolbar. 

HFSS checks the project setup, and then the Validation 
Check window appears. 

2  View the results of the validation check in the Validation 
Check window. 

For this antenna project, a green check mark should 
appear next to each project step in the list. 

3  Click Close. 
4  Click File>Save to save any changes you have made to 

your project. 
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Generate the Solution
Now that you have entered all the appropriate solution crite-
ria and defined the mesh operations, the antenna problem is 
ready to be solved. 
When you set up the solution criteria, you specified values for 
an adaptive analysis. An adaptive analysis is a solution process 
in which the mesh is refined iteratively in regions where the 
error is high, which increases the solution’s precision. You set 
the criteria that control mesh refinement during an adaptive 
field solution. Many problems can be solved using only adap-
tive refinement.
The following is the general process carried out during an 
adaptive analysis:
1  HFSS generates an initial mesh.

2  Using the initial mesh, HFSS computes the electromagnetic 
fields that exist inside the structure when it is excited at 
the solution frequency. (If you are running a frequency 
sweep, an adaptive solution is performed only at the spec-
ified solution frequency.)

3  Based on the current finite element solution, HFSS esti-
mates the regions of the problem domain where the exact 
solution has strong error. Tetrahedra in these regions are 
refined.

4  HFSS generates another solution using the refined mesh. 
5  The software recomputes the error, and the iterative pro-

cess (solve — error analysis — refine) repeats until the con-
vergence criteria are satisfied or the requested number of 
adaptive passes is complete.

6  If a frequency sweep is being performed, HFSS then solves 
the problem at the other frequency points without further 
refining the mesh.

To begin the solution process:
1  Select the Setup1 solution setup in the project tree.

2  Click HFSS>Analyze. This command solves every solution 
setup in the design.
HFSS computes the 3D field solution inside the structure.
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The Progress window displays the solution progress as it 
occurs: 

View the Solution Data
While the analysis is running, you can view a variety of pro-
file, convergence, and matrix data about the solution. 

View the Profile Data
While the solution proceeds, examine the computing 
resources or profile data, that were used by HFSS during the 
analysis. 
The profile data is essentially a log of the tasks performed by 
HFSS during the solution. The log indicates the length of time 
each task took and how much RAM/disk memory was 
required.
To view the solution’s profile data:
•    Click HFSS>Analysis Setup>Profile.

The Solution Data window appears. The figure shows the 
Profile tab selected.

Note The results that you obtain should be approximately the 
same as the ones given in this section. However, there may 
be a slight variation between platforms.
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Notice in the Simulation pull-down list that Setup1 is 
selected as the solution setup. By default, the most 
recently solved solution is selected.
For the Setup1 solution setup, you can view the following 
profile data:
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View Convergence Data
Next, while the solution proceeds, view the convergence 
data. 

Task Lists the software module that performed a task 
during the solution process, and the type of task 
that was performed. 
For example, for the task mesh3d_adapt, Mesh3d 
is the software module that adaptively refined the 
mesh.

Real Time The amount of real time (clock time) required to 
perform the task.

CPU Time The amount of CPU (Central Processing Unit) time 
required to perform the task.

Memory The amount of RAM/virtual memory required of 
your machine to complete the task. This value 
includes the memory required of all applications 
running at the time, not just HFSS.

Information The number of triangles, tetrahedra and matrices 
generated.
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To view a solution’s convergence information:
•    In the Solution Data window, click the Convergence tab.

Based on the criteria you specified for Setup1, you can 
view the following convergence data:

•    Number of adaptive passes completed and remaining.
When the solution is complete, you can view the number 
of adaptive passes that were performed. If the solution 
converged within the specified stopping criteria, fewer 
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passes than requested may have been performed.
•    Number of tetrahedra created at each adaptive pass.
•    Maximum magnitude of delta S between two passes.

For solutions with ports, as in Setup1, at any time during 
or after the solution process, you can view the maximum 
change in the magnitude of the S-parameters between two 
consecutive passes. This information is available after two 
or more passes are completed.
The convergence data can be displayed in table format or 
on a rectangular (X - Y) plot.

View Matrix Data
Next, view matrices computed for the S-parameters, imped-
ances, and propagation constants during each adaptive and 
sweep solution. 
To view matrices:
1  In the Solution Data window, click the Matrix Data tab.

2  In the Simulation pull-down lists, do the following:
a. Verify that Setup1 is selected as the solution setup for which 
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you want to view matrices.
b. Verify that LastAdaptive is selected. This is the solved pass for 

which you want to view matrices. 
3  Select S Matrix as the type of matrix data you want to 

view. 
4  Select Magnitude/Phase from the pull-down list as the for-

mat in which to display the matrix information. 
You can display matrix data in the following formats:

5  Select the solved frequencies to display:
•    To display the matrix entries for all solved frequencies, 

select All Freqs. It is selected be default.
•    To show the matrix entries for one solved frequency, clear 

All Freqs and then select the solved frequency for which 
you want to view matrix entries. 
For adaptive passes, only the solution frequency specified 
in the Solution Setup dialog box is available. For fre-
quency sweeps, the entire frequency range is available.
The data is displayed in the table.

6  Click Close to close this window.
Once the simulation has run successfully, you will be ready 
to analyze the results, as described in the next chapter, 
“Analyzing the Solution.”

Magnitude/
Phase

Displays the magnitude and phase of the matrix 
type.

Real/
Imaginary

Displays the real and imaginary parts of the matrix 
type.

dB/Phase Displays the magnitude in decibels and phase of 
the matrix type.

Phase Displays the phase of the matrix type.

Real Displays the real parts of the matrix type.

Magnitude Displays the magnitude of the matrix type.

Imaginary Displays the imaginary parts of the matrix type.

dB Displays the magnitude in decibels of the matrix 
type.



Analyzing the Solution 6-1
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

6 Analyzing the Solution

Now, HFSS has generated a solution for the antenna problem. In gen-
eral, you can display and analyze the results of a project in many dif-
ferent ways. You can:
• Plot field overlays - representations of basic or derived field 

quantities - on surfaces or objects. 
• Create 2D or 3D rectangular or circular plots and data tables of S-

parameters, basic and derived field quantities, and radiated field 
data.

• Plot the finite element mesh on surfaces or within 3D objects.
• Create animations of field quantities, the finite element mesh, 

and defined project variables.
• Scale an excitation’s magnitude and modify its phase.
• Delete solution data that you do not want to store.

For this antenna problem, you will specifically: 
D�Create Modal S-parameter reports. 
D�Create a field overlay plot of the magnitude of E on the top face 

of the antenna’s cavity.
D�Create an animation of the mag-E plot.

Time It should take you approximately 1 hour to work through this chapter. 
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Create Modal S-Parameters Reports
Now you are ready to create the modal S-parameters and Z-parameters 
reports. 

Create an S-Parameters Report of S11
To generate a 2D report of S11:
1  Click HFSS>Results>Create Modal Solution Data Report>Rectangu-

lar Plot.

The New Report dialog box appears. 

2  Verify that Setup1: Sweep1 is selected in the Solution pull-down list. 
3  Verify that Sweep is selected from the Domain pull-down list.
4  For the Primary Sweep, select the variable Freq. 

This selection is plotted along the x-axis. 
5  In the Y Component pane, specify the following information to plot 
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along the y-axis:

6  In the Families tab, the Sweeps radio button is selected. 
7  Click New Report, and then click Close. 

The report XY Plot 1 appears in the 3D Modeler window and is now 
listed under Results in the project tree. A trace icon is also listed 
under XY Plot 1. A trace is a single line that connects the data points 
on the graph.

Category S Parameter
This is the type of information to plot. 

Quantity S(LumpPort1,LumpPort1)
This is the value to plot. 

Function dB
This is the mathematical function of the quantity to 
plot.
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Create an S-Parameters Report of Z11
To generate a 2D report of Z11 Real and Imaginary traces:
1  Click HFSS>Results>Create Modal Solution Data Report>Rectangu-

lar Plot.

The Report dialog box appears.
2  Verify that Setup1: Sweep1 is selected from the Solution pull-down 

list. 
3  Verify that Sweep is selected from the Domain pull-down list.
4  For the X field, the sweep variable Freq is selected. 

This select plots the sweep variable selected along the x-axis. 
5  In the Y pane, add the following two traces to plot along the y-axis:

a. Specify these values for the real trace to plot: 

b. Click New Report, but do not click Close.
This displays the XY Plot 2 report with one trace and enables the 
Update Trace and Add Trace buttons in the New Report dialog.

c. In the New Report dialog, specify these values for the imaginary 
trace to plot: 

6  Click Add Trace. 

Category Z Parameter

Quantity Z(LumpedPort1, LumpedPort1)

Function re
This is the real part of the complex number. 

Category Z Parameter

Quantity Z(LumpedPort1, LumpedPort1)

Function im
This is the imaginary part of the complex number. 
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The Z-parameter trace is added to the XY Plot 2 in the 3D Modeler 
window and is now listed under the Results icon in the project tree. 
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Create Field Overlay Plots
Next, you will create a field overlay plot of the magnitude of E of the 
bottom face of the antenna’s air volume object and examine the result-
ing E- field pattern. 

Create a Mag E Field Overlay Plot
Now, you are ready to create a field overlay plot of the magnitude of E of 
the bottom face of the air volume object and examine the resulting E- 
field pattern. 
1  In Select Faces mode, select the bottom face of the object airvol. 

One way to do this is to click the cursor near the bottom of one of the 
rectangular facets, and then type “b” to select a face behind.

2  On the HFSS menu, click Fields>Plot Fields>E>Mag_E. 
The Create Field Plot dialog box appears. 



Getting Started with HFSS: A Dielectric Resonator Antenna

Analyzing the Solution 6-7
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

3  Select Mag_E from the Quantity list. 
This selects the magnitude of the real part of the electric field 
|E|(x,y,z,t) as the quantity to plot.

4  Select All from the In Volume list to specify that HFSS will plot over 
the entire volume of the model.

5  Verify that 3.75GHz is selected from the Freq pull-down list. 
The Freq pull-down list includes a list of frequencies for which a field 
solution is available.

6  Verify that 0deg is selected from the Phase pull-down list.
7  Click Done.

The Mag_E1 field overlay cloud plot appears in the 3D Modeler win-
dow and is now listed under Field Overlays-E Field-Mag_E1 in the 
project tree. 
Your field overlay plot should resemble the one shown below: 
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Modify the Mag E Plot’s Attributes
Now, you will modify the attributes of the Mag_E1 field overlay plot you 
just created to prepare it for an effective animation. 
1  Select Mag_E1 in the project tree under Field Overlays-E Field. 

This is the folder in which plot Mag_E1 is located. 
2  On the HFSS menu, point to Fields, and then click Modify Attributes. 

The Select Plot Folder window appears. 

3  Verify that Mag_E1 is selected, and then click OK. 
A dialog box appears, which displays the plot’s attributes. 
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4  Click the Color map tab, and then specify the following settings:

5  Click the Scale tab, and then specify the following settings: 

6  Click the Plots tab, and then specify the following settings: 

7  Accept all the remaining default settings in this dialog box. With Real 
Time Mode selected, Apply is grayed out, and the changes apply 
immediately. 

Type Select Spectrum and Rainbow from the pull-down 
list. 
Field quantities are plotted in multiple colors. Each 
field value is assigned a color from the selected 
spectrum.

Real time 
mode

Select this option.
This option immediately applies changes to the 
plot’s attributes. 

Use Limits Select this option.
Only the field values between the minimum and 
maximum values will be plotted. Field values below 
or above these values will be plotted in the colors 
assigned to the minimum or maximum limits, 
respectively.

Min Enter 1e-4 (0.0001). 

Max Enter 1e5 (100000).

Linear/ Log Select Log. 
Field values will be plotted on a logarithmic scale.

IsoValType Select Tone from the pull-down list. 
This isosurface display type varies color continuously 
between isovalues.

Outline Select this option. 

Map transp. Clear this option, if it is selected. 
If selected, the transparency of field values 
increases as the solution values decrease.
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Your modified plot Mag_E1 should resemble the one shown below: 

Create a Phase Animation of the Mag E Plot
Next, you will create an animation of the field overlay plot of the magni-
tude of E to examine a frame-by-frame, animated behavior of the plot. 
To create a phase animation of the Mag E plot: 
1  Select the Mag_E1 field overlay plot from the project tree.

2  Click HFSS>Fields>Animate.
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The Setup Animation dialog box appears. 

3  Accept the default name Animation1 in the Name text box.
4  Optionally, type a description of the animation in the Description 

text box.
5  Under the Swept Variable tab, select Phase from the Swept Variable 

list.
6  Accept the remaining default settings in the Start, Stop, and Steps 

boxes for the phase values of the animation. 
If the Start value is 0, the Stop value is 160, and the number of steps 
is 9, the animation will display the plot at 9 phase values between 0 
and 160. The start value will be the first frame displayed, resulting in 
a total of 10 frames in the animation.

7  Click OK.
The animation begins in the 3D Modeler window. The play panel 
appears in the upper-left corner of the desktop, enabling you to stop, 
restart, and control the speed and sequence of the frames.
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