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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in this 
guide.

• Procedures are presented as numbered lists. A single bullet indicates that the procedure has only 
one step.
Bold type is used for the following:
- Keyboard entries that should be typed in their entirety exactly as shown. For example, “copy 

file1” means the word copy must be typed, then a space must be typed, and then file1 must 
be typed.

- On-screen prompts and messages, names of options and text boxes, and menu commands. 
Menu commands are often separated by carats. For example, “click HFSS>Exci-
tations>Assign>Wave Port.”

- Labeled keys on the computer keyboard. For example, “Press Enter” means to press the key 
labeled Enter.

• Italic type is used for the following:
- Emphasis.
- The titles of publications.
- Keyboard entries when a name or a variable must be typed in place of the words in italics. For 

example, “copy file name” the word copy must be typed, then a space must be typed, and 
then name of the file must be typed.

• The plus sign (+) is used between keyboard keys to indicate that you should press the keys at the 
same time. For example, “Press Shift+F1” means to press the Shift key and the F1 key at the 
same time.

• Toolbar buttons serve as shortcuts for executing commands. Toolbar buttons are displayed after 
the command they execute. For example,

• “On the Draw menu, click Line ” means that you can click the Draw Line toolbar button to 
execute the Line command.
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Getting Help: ANSYS Technical Support

For information about ANSYS Technical Support, go to the ANSYS corporate Support website, 
www.ansys.com/Support. You can also contact your ANSYS account manager in order to obtain this 
information.

All ANSYS (0�software files are ASCII text and can be sent conveniently by e-mail. When reporting 
difficulties, it is extremely helpful to include very specific information about what steps were taken or 
what stages the simulation reached, including software files as applicable. This allows more rapid and 
effective debugging.

Help Menu

To access online help from the HFSS menu bar, click Help and select from the menu:

Contents - click here to open the contents of the online help.

Search - click here to open the search function of the online help.

Index - click here to open the index of the online help.

Context-Sensitive Help

To access online help from the HFSS user interface, do one of the following:

• To open a help topic about a specific HFSS menu command, press Shift+F1, and then click the
command or toolbar icon.

• To open a help topic about a specific HFSS dialog box, open the dialog box, and then press F1.

www.ansys.com/Support
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1 Introduction

This document is intended as supplementary material to 
HFSS for beginners and advanced users. It includes 
instructions to create, solve, and analyze a Ridged Horn 
Antenna. We assume you already have some experience 
using HFSS in the frequency domain.



Getting Started with HFSS: A Ridged Horn Antenna

1-2 Introduction 
  ANSYS Electromagnetics Suite 15.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Sample Project: Transient Horn Antenna
In this project, you will use HFSS Transient to obtain the 
broad-band S-parameters of a ridged horn antenna. A broad-
band antenna such as this can be used to transmit short-dura-
tion pulses, e.g. as part of a ground-penetrating radar (GPR) 
system for the detection of buried pipes or land mines. HFSS 
Transient is the tool of choice to simulate the interaction of a 
short-duration electromagnetic signal in the time domain with 
the antenna and with buried objects.
We will open a model containing the antenna geometry, cre-
ate the rest of the model, and set up a Transient Network 
Analysis. We will run the simulation and inspect some results.

Figure 1. Sample Project
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2 Setup the Transient 
Model

This chapter guides you through the preparation of a 
model for a transient simulation in HFSS.
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Start HFSS and Open the Model
We recommend that you store a short-cut of the HFSS applica-
tion on your desktop.
1  Double-click the HFSS icon to open the application.

2  Use File>Open to load the file broadbandhorn.hfss from 
the Help folder in the HFSS installation.
Note   Since the project is deliberately incomplete it is 
located in the Help folder as opposed to the Examples 
directory. You will add excitations and a setup before 
analyzing the model and generating reports. 
Note   A sample path could be C:\Program 
Files\AnsysEM\HFSSn\Win64 or 32\Help.

.

Figure 1. Horn Antenna Model

Verify Solution Type
1  On the Project Manager window, right click the option 

HFSSDesignn(Transient Network) under broadbandhorn 
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and select Solution Type from the short-cut menu.
.

Figure 2. Solution Type

2  Ensure the option Network Analysis is selected and click 
OK.

3  Save the project in a different directory of your choice.

Assign Material to Horn and Pin
Notice that the options horn and pin in the history tree 
appear under Not Assigned.
1  Double-click horn to open the Attribute dialog box.

2  Set Material property as copper.
3  Click OK to close the Attribute dialog box.
4  Double-click pin to open the Attribute dialog box.
5  Set Material property as copper.
6  Click OK to close the dialog box.

Complete the Geometry 
Complete the geometry by creating an air box and PMLs. 
1  Create an air box with starting vertex (X,Y,Z)=(-100, -250, 

-180) and size (dX, dY, dZ)=(550, 500, 360).

Note   Ensure the fields in the command dialog box are set 
as shown in the figure below.
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Figure 3. Command dialog box

The faces of this box are at a distance of 100 mm or more 
from the horn. Since we are going to use PMLs and the mini-
mum frequency will be 0.7 GHz, this is much more strict than 
necessary, but is still of a reasonable size.
2  Assign air as the Material, and enter a name, a color and a 

transparency of your choice on the Attribute dialog box as 
shown below.

Figure 4. Attribute dialog box
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3  Select all faces of the air box.
4  On the toolbar click HFSS>Boundaries>PML Setup Wiz-

ard.
5  Edit the thickness: 100 mm. See Figure 5 below.

Note   The thickness set is somewhat arbitrarily, since the 
wizard will adjust the material parameters to obtain good 
absorption at a given thickness.

.

Figure 5. Specifying the thickness

6  Click Next.
7  Set the fields in the PML Setup Wizard: Material Parame-

ters dialog as shown in Figure 6.
Note   These specifications are needed to enable HFSS to 
generate the correct absorbing materials, materials that 
absorb very well at the given layer thickness, frequency 
and distance from the nearest part of the radiating 
structure, and that absorb even better at higher 
frequencies and larger distances.
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Figure 6. PML Setup Wizard: Material Parameters

8  Click Next and then, click Finish.

Specify Surfaces for Plotting Fields
We need to decide at an early stage where we want to visual-
ize fields, since saving fields in the entire 3D model at every 
time step is not practical. We will create two rectangles 
where we want to save fields.
1  Create a rectangle in the XY plane starting at (X,Y,Z)=

(-100, -250, 0) with size (Xsize, Ysize)=(550, 500).
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Figure 7. Command dialog 

2  Create a rectangle in the XZ plane starting at (X,Y,Z)=
(-100, 0, -180) with size (Xsize, Zsize)=(550, 360).

Figure 8. Command dialog

3  Display both rectangles as wire frames.
We need to define a “list” in order to specify later that we 
wish to save fields here.

4  Select both rectangles.
5  Modeler>List>Create>Object List (or Face List if you 

selected them in face-select mode)
6  Name the list as “PlotFields”, as shown below, through the 

Model Tree and the Properties.
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.

Figure 9. Changing the name “Objectlist1” to “PlotFields” 

7  Save the model.

Boundaries
PML Radiation faces were defined when the PMLs were cre-
ated. Expand Boundaries on the project tree to see the list.

Figure 10. PML boundaries list
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Assign Excitations
The sheet object “source” will be a wave port. 
1  Click Tools>Options>HFSS Options to see the HFSS 

Options dialog box.

Under the General tab, under Assignment Options see that 
you have unchecked Auto-assign terminals on ports, and 
click OK.

Figure 11. Assignment Options

2  To locate the source, select it from the history tree and 
then, use the option Drag rectangle using left mouse to 
zoom in the camera. 

Figure 12. zoom-in to see the source
Note   Notice how this object can serve as the source of a 
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co-axial cable of which the outer conductor is part of one 
ridge and the inner conductor connects to the opposite 
ridge.

3  Assign a Wave Port to this sheet object. 
4  Give the name as p1 and click Next.
5  Specify that the port will be Active. Click Next.

Figure 13. Specify port to be active.

6  Select Do Not Renormalize. 
The port impedance is expected to be close to 50 Ohm, 
and seeing the actual impedance can confirm that the 
model has been set up correctly.

Figure 14. Final step in setting up the wave port

7  Click Finish.
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Explanation of Active Ports
In a Transient Network Analysis design with multiple ports, in 
order to obtain the full S-matrix, the ports will be ON one at a 
time for a full 3D simulation. Each simulation with a particu-
lar port ON will produce one column of the S matrix. When 
you specify a port as passive, it will only act as termination. 
This saves simulation time, at the expense of not generating 
the particular column of S-parameters.
In a general Transient (non network analysis) design, all active 
ports will be ON simultaneously, while the remaining passive 
ports will act as terminations only.
In both cases, the distinction between active and passive 
ports gives you flexibility.

Specify a Terminal
Since HFSS Transient uses Terminal-Driven ports, we need to 
specify a terminal. 
1  Right-click p1 in the project tree and select Auto Assign 

Terminals from the short-cut menu.

Figure 15. Auto-assigning terminals once the port has been defined

2  Specify the horn as Reference, so the pin will be the ter-
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minal.

Figure 16. Specify the conductor touching the port to be the reference

Zoom in to see the terminal associated with the wave port.
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Figure 17. terminal
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3 Simulation and Results

This chapter describes how to setup the transient simula-
tion for the horn antenna and view the results.
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Solution Setup
1  In the Project Tree, select Analysis>Add Solution Setup.

2  The mesh for the transient simulation is generated by a 
regular frequency-domain simulation. For that simulation, 
the software will decide on the appropriate frequency at 
which to perform the adaptive passes. It will use mixed 
element orders and the iterative solver. Accept the 
defaults under the General tab.

Figure 1. General tab

3  Under the Input Signal tab, specify the frequency band of 
interest as shown below. This band is covered by a modu-
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lated Gaussian pulse in the time domain, as can be seen in 
the panel.

Figure 2. Input Signal

4  Under the Duration tab, you specify limits for the simu-
lated time of the transient analysis. For this exercise, 
select Auto Terminate.
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Figure 3. Duration tab

The Target Residual is based on the maximum field 
remaining in the model at a given time, relative to the all-
time high. Once the fields have fallen below 0.001 of the 
all-time high, the simulation can safely be stopped. Addi-
tionally, you can specify a maximum and a minimum time 
span to be simulated. The built-in maximum and minimum 
time spans are appropriate in most simulations. They take 
the model size and the type of signal into account. Only in 
special cases you may find that you need to override the 
defaults.

5  Under the Saved Fields tab, check the Object List or Face 
List you defined earlier. Ask for fields to be saved every 30 
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ps. This is a small-enough fraction of the duration of the 
broadband pulse to obtain a smooth field animation later 
on. 

Figure 4. Saved Fields

6  Under the Radiated Fields tab, ask for both time-domain 
radiated fields and frequency-domain radiated fields at 
1.2 GHz, as shown below.
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Figure 5. Radiated Fields

7  The Solution Setup is complete. Click OK.

Simulation
1  Run the simulation.

The progress bar is based on the maximum simulated time 
from the Duration tab in the Solution Setup, or, if none is 
specified, on 20×(model diagonal)/(speed of light). In gen-
eral, the simulation is done well before the progress bar has 
reached its maximum length.
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Figure 6. Progress bar, displaying simulated time relative to its maximum

While the simulation is running, you can follow its progress 
in other ways.

2  Right-click on Results in the project tree and select Cre-
ate Terminal Solution Data Report>Rectangular Plot.
Plot the quantities Input and Output in one report. Plot 
Residual in dB20 in another.
Input and Output show the excitation and the reflection in 
the port as a function of time.
Residual shows a measure for the maximum field level in 
the model. The simulation is complete when Residual falls 
below 0.001 of its all time peak. Change the setting to 
Volts from mV to view the results. 
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Figure 7. Modify from mV to Volts
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Figure 8. Input and Output in volts (excitation and reflection) as a function of time
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Figure 9. Residual on a log scale, as a function of time

Report
1  To plot S-parameters as a function of frequency, again 

right-click on Results in the project tree and select Create 
Terminal Solution Data Report>Rectangular Plot. 

2  Change the Solution to Spectral as shown below.

Figure 10. Preparing a report of S-parameters as a function of frequency, in the Spectral Solution

3  Plot the magnitude of S11. 
The resulting report is shown below. This report can also 
be generated while the simulation is still running. That 
enables you to see at an early stage where the results are 
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headed.

Figure 11. 
|S11| for the broad-band horn

Field Overlay
1  To create a field overlay, select the list named “plot-

fields” in the model tree, i.e. the list containing the two 
rectangles you had created for the purpose of field plot-
ting.

2  In the Project Tree, right-click  Field Overlays>Plot 
Fields>E_t>Mag_E_t and select an arbitrary nonzero time 
in the next panel. You can always adjust the time later by 
right-clicking the plot name and selecting Modify.
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Figure 12. Field Overlay at 3.044ps
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The field overlay is created.

Figure 13. Example field overlay

3  Change the scale to make it range from 0 to 10 V/m.
4  Animate the plot by right-clicking on the plot name and 

selecting Animate.
In the Setup Animation window, you can adjust the num-
ber of steps. If necessary, HFSS will interpolate between 
saved field solutions.
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Figure 14. Setup Animation window

Radiated Fields
1  To compute transient radiated fields, right-click on Radia-

tion in the Project tree and select Insert Far Field 
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Setup>Infinite Sphere

Figure 15. Inserting a far-field setup

2  In the Project Manager, right-click on Radiation and select 
Insert Far-Field Setup>Infinite Sphere. Specify a range of 
interest as shown. This range is in the XZ plane, and spans 
from zenith to nadir in the “forward” direction of the 
antenna
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Figure 16. Specifying only one point on the far-field sphere

3  Next, in the Project tree, right-click Results>Create Far-
Fields Report>Rectangular Plot

4  Create a report of rEz as a function of time.
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Figure 17. reports panel
5  Under the Families tab, specify Theta=90 deg and phi=0 

deg, the center of the main beam.

Figure 18. Families tab

Explanation: Ez is the dominant, co-polarized, component 
of E. The product of r (distance) and Ez is practical 
because it’s independent of distance in the far field. The 
unit of rE is Volt, since the unit for E is V/m which is multi-
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plied, through r, by meters. The question is sometimes 
asked which distance HFSS uses in this calculation. The 
distance is infinite. The expression for far radiated fields 
has the form E=U/r where U contains an integral over radi-
ation surfaces and r approaches infinity. Multiplying both 
sides by r yields an expression for rE at infinity without the 
need to evaluate the radiated E at a finite distance. 
The figure below shows the shape of the far radiated field 
along the main beam. A plot like this is instrumental in 
determining how the original excitation is distorted by the 
antenna. Information like this can be used to improve the 
antenna design, e.g. by judiciously placing resistive strips 
in certain locations to suppress late-time ringing. It is also 
useful information in the development of signal-processing 
algorithms.

Figure 19. Far radiated field, co-polarized, in the center of the main beam. 

Optionally, you can also create a frequency-domain far field 
by changing the solution to spectral and changing the primary 
sweep to Theta, as shown below.
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Figure 20. panel
Under the families tab, you will notice that the frequency of 
1.2 GHz, specified earlier under the Radiated-Fields tab of 
the Solution Setup, is automatically available.
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